Searching \ for 'WAKEUP of 16C73 by synchronous slave RX' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: techref.massmind.org/techref/microchip/ios.htm?key=rx
Search entire site for: 'WAKEUP of 16C73 by synchronous slave RX'.

Truncated match.
PICList Thread
'WAKEUP of 16C73 by synchronous slave RX'
1998\05\27@174447 by Amundsen, Finn

flavicon
face
I have a problem getting the 16C73 controller out of sleep by use of
the USART synchronous slave receiver. Tests shows that
a character is received when sleep is not entered.
The controller also gets out of sleep by use of external signal on INT
pin.
My code is as follows:

/* Initialise serial port */
  SYNC  = 1;     /* Select synch mode */
  SPEN  = 1;     /* Enable serial port */
  CSRC  = 0;     /* Slave mode */
  GIE   = 0;     /* Disable interrupts */
  RCIE  = 1;     /* Enable wakeup */
  temp = RCREG;
  CREN  = 1;     /* Enable reception   */

/* TEST that receive works */
/* while (TRUE){                   */
/*    if(RCIF) nop();      */
/* }                       */

   sleep();      /* while waiting for synch data */
   nop();              /* Continue execution */


If you can make any suggestions, I would  appreciate it.

Thank you,

Finn L. Amundsen

1998\05\27@182655 by Mike Keitz

picon face
On Wed, 27 May 1998 23:03:03 +0200 "Amundsen, Finn"
<spam_OUTFinn.AmundsenTakeThisOuTspamCAPGEMINI.NO> writes:
>I have a problem getting the 16C73 controller out of sleep by use of
>the USART synchronous slave receiver.

It can't work.  Even in slave mode, the SSP requires the PIC instruction
clock.  So it won't receive anything during sleep.  It will detect a
start or stop condition in IIC mode and wake up, but that's all.

_____________________________________________________________________
You don't need to buy Internet access to use free Internet e-mail.
Get completely free e-mail from Juno at http://www.juno.com
Or call Juno at (800) 654-JUNO [654-5866]

1998\05\28@074350 by Amundsen, Finn

flavicon
face
Thanks for the answer Mike.
The problem is related to use of the USART in synchronous mode, not the
SSP.
It should work according to the data sheet. Can anyone help?
For more info see the original mail.

==
Finn.

> {Original Message removed}

More... (looser matching)
- Last day of these posts
- In 1998 , 1999 only
- Today
- New search...