Searching \ for 'SSP in SPI Mode' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: techref.massmind.org/techref/io/serial/spis.htm?key=spi
Search entire site for: 'SSP in SPI Mode'.

Truncated match.
PICList Thread
'SSP in SPI Mode'
1997\05\02@184717 by Andy Kunz

flavicon
face
Until today, I've only done SPI in software.  Now I'd like to use the SPI
module in a '74A, but can't seem to get it to work.  In particular, BF is
staying clear when it should be a "1" on startup.

Anybody every used it?  Pointers?

Thanks.

Andy

==================================================================
Andy Kunz - Montana Design - 409 S 6th St - Phillipsburg, NJ 08865
         Hardware & Software for Industry & R/C Hobbies
       "Go fast, turn right, and keep the wet side down!"
==================================================================

1997\05\02@213750 by wft

face
flavicon
face
Andy Kunz wrote:
>
> Until today, I've only done SPI in software.  Now I'd like to use the SPI
> module in a '74A, but can't seem to get it to work.  In particular, BF is
> staying clear when it should be a "1" on startup.
>
> Anybody every used it?  Pointers?
>
> Thanks.
>
> Andy
>
I am about to try getting SPI going on a "74A".  I will let you know how
it goes.

Gus

1997\05\03@060257 by Octavio Nogueira

flavicon
face
>Until today, I've only done SPI in software.  Now I'd like to use the SPI
>module in a '74A, but can't seem to get it to work.  In particular, BF is
>staying clear when it should be a "1" on startup.
>
>Anybody every used it?  Pointers?
>
>Thanks.
>
>Andy


I'm having the same problem, I'm using a 74 and a 65 and I had to SPI
in software. Any clue will help.

Thanks,

Octavio
======================================================
Octavio Nogueira  - e-mail:   spam_OUTnogueiraTakeThisOuTspammandic.com.br
http://www.geocities.com/~oct_nogueira
"ProPic" Production PIC Programmer Windows under US$20
======================================================

1997\05\03@100342 by Andy Kunz

flavicon
face
At 06:55 AM 5/3/97 -0300, you wrote:
>>Until today, I've only done SPI in software.  Now I'd like to use the SPI
>>module in a '74A, but can't seem to get it to work.  In particular, BF is
>>staying clear when it should be a "1" on startup.

Nothing like solving your own problems.

For all interested, I have sent to Octavio the code (with comments) that
solves the problem, most of it anyway.  I have asked him to post it on his
page.

If you prefer, I'd be happy to e-mail you a copy.  Just ask me privately,
not via the list.  I will ignore requests coming through the list.

.....montanaKILLspamspam@spam@fast.net

Andy

==================================================================
Andy Kunz - Montana Design - 409 S 6th St - Phillipsburg, NJ 08865
         Hardware & Software for Industry & R/C Hobbies
       "Go fast, turn right, and keep the wet side down!"
==================================================================

More... (looser matching)
- Last day of these posts
- In 1997 , 1998 only
- Today
- New search...