Searching \ for '84 not clocking' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: techref.massmind.org/techref/timers.htm?key=clock
Search entire site for: '84 not clocking'.

Truncated match.
PICList Thread
'84 not clocking'
1999\04\06@152103 by Paul Fletcher

picon face
I have a real strange clock issue that I'm hoping someone else has
seen, I have a very simple setup with a 'c84 being driven from a 4Mhz
xtl, but its not working.

If I 'scope pin 16 it is sitting there at 0v, and pin 15 has a very
small
(< 2 volt) sine wave at around 200Khz. I have checked and rechecked the
board and tried another PIC but still the same. I have also checked the
fuses are OK.

Can anyone help ???

Paul Fletcher.

1999\04\06@153349 by Nick Taylor

picon face
Paul - -
check the simple (and easily overlooked) things first.  Is the
proper oscillator selected?
- - - Nick - - -

Paul Fletcher wrote:
<snip>
> I have a real strange clock issue that I'm hoping someone else has
> seen, I have a very simple setup with a 'c84 being driven from a 4Mhz
> xtl, but its not working.
> Can anyone help ???

1999\04\06@163742 by hmiller

picon face
Paul Fletcher wrote:
>
> I have a real strange clock issue that I'm hoping someone else has
> seen, I have a very simple setup with a 'c84 being driven from a 4Mhz
> xtl, but its not working.
>
> If I 'scope pin 16 it is sitting there at 0v, and pin 15 has a very
> small
> (< 2 volt) sine wave at around 200Khz. I have checked and rechecked the
> board and tried another PIC but still the same. I have also checked the
> fuses are OK.
>
> Can anyone help ???
>
> Paul Fletcher.
=====================

Paul

I had the same problem when I started, it turned out that I was
programming the chip in the RC mode. I found out how to change to the
XTL mode and the thing worked. The thing is, when you get the easy
problems solved, then you have to deal with more complex ones. 8-)

Harley

1999\04\06@164006 by MEDICINTEKNIK KB

picon face
Check the capacitors, and obey the datasheets on that point. Parallell/serial XTAL OK ?


Sven
-----Ursprungligt meddelande-----
FrŒn: Paul Fletcher <spam_OUTp.fletcherTakeThisOuTspamBIGFOOT.COM>
Till: .....PICLISTKILLspamspam@spam@MITVMA.MIT.EDU <PICLISTspamKILLspamMITVMA.MIT.EDU>
Datum: den 6 april 1999 21:21
€mne: 84 not clocking


{Quote hidden}

1999\04\06@185345 by Alice Campbell

flavicon
face
Hi   Paul

> If I 'scope pin 16 it is sitting there at 0v, and pin 15 has a very
> small
> (< 2 volt) sine wave at around 200Khz. I have checked and rechecked the
> board and tried another PIC but still the same. I have also checked the
> fuses are OK.

well, actually im chasing a similar problem on my first(!)
soldered pic pcb, although for 33 khz.  questions:
is your scope on the actual pic pin, or on the crystal lead, or
somewhere else? i discovered a bad solder joint between the
capacator and xl-- the pin had power, but the leg of the crystal
didnt.

second thing:  i discovered that my board did not have a trace
connecting the crystal's caps to ground.  it was ok on the
protoboard, but i missed it on the board layout. just found it sunday
afternoon.  Also, i had forgotten to install the cap bypassing vcc to
ground.  (the poor quality of help these days...)

however, i can now only get the thing to run if i have the DVM
probe on the pics osc1 pin.  go figure.  im stumped on that one.
guys?

good luck,
alice

1999\04\06@190413 by Richard Katezansky

flavicon
face
Try on of the following.

1; Make sure you have the oscillator programmed right (LP in this case).

2; Place a high value resistor (1M - 10M Ohm) across the crystal or a low
value resistor (100 - 1K Ohm) in series.

At 12:08 AM 4/6/99 -0800, you wrote:
{Quote hidden}

1999\04\21@205329 by Larry G. Nelson Sr.

flavicon
face
Try unbalancing the caps. Sometimes the crystal startup is not good but
changing one of the two caps to unbalance the circuit can sometimes fix
things.


At 12:08 AM 4/6/99 PST, you wrote:
{Quote hidden}

Larry G. Nelson Sr.
.....L.NelsonKILLspamspam.....ieee.org
http://www.ultranet.com/~nr

More... (looser matching)
- Last day of these posts
- In 1999 , 2000 only
- Today
- New search...