Searching \ for '[PIC]: 12f675 problems' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: techref.massmind.org/techref/microchip/devices.htm?key=pic
Search entire site for: '12f675 problems'.

Exact match. Not showing close matches.
PICList Thread
'[PIC]: 12f675 problems'
2003\04\22@055429 by Jason Dini

flavicon
face
Hi,

I am busy trying to program a 12f675 to flash an LED. When I compile my code
in MPLab I get message [302]: 'Register in operand not in bank0'. This
worries me as my registers are pretty important to my code actually doing
anything.  The odd thing is when I downloaded some sample code from the
Microchip website for the 12f629 (very similar except for the a/d converter)
I find that their code purposely suppresses these messages!?! Anyway at the
end of the day my very basic code doesn't work. I then proceeded to download
a blinking led hex file from Wouter van Ooijen's website and that works
perfectly. It would seem that the problem definely lies in my code - which I
have checked and rechecked - or in the assembly process. I can't find sample
code for this pic anywhere. Anybody have any clues or assembler templates
for the 12f675?

Thanks in advance.

Regards
Jason Dini

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads

2003\04\22@061508 by Thomas C. Sefranek

face picon face
You probably should post your code.
I use the warnings to check that I have properly selected the bank
before I use the register's).

 *
 |  __O    Thomas C. Sefranek   spam_OUTWA1RHPTakeThisOuTspamARRL.NET
 |_-\<,_   Amateur Radio Operator: WA1RHP
 (*)/ (*)  Bicycle mobile on 145.41, 448.625 MHz

hamradio.cmcorp.com/inventory/Inventory.html
http://www.harvardrepeater.org

> {Original Message removed}

2003\04\22@064244 by erholm (QAC)

flavicon
face
The [302] message just tells you to (re-)check that you
are setting the bank bits correctly. MPASM does *not*
check this ! (It's a "message", not an "error"...)

So, no matter how "correct" your code is, you will still
get the [302] message until you purposely suppress it, just
as the Microchip sample does.

And, you could probably post your blink-a-LED code, it can't
be to many lines, right :-)

Jan-Erik Soderholm.

Jason Dini wrote:

>Hi,
>
>I am busy trying to program a 12f675 to flash an LED. When I compile my code
>in MPLab I get message [302]: 'Register in operand not in bank0'.

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads

2003\04\22@083338 by Olin Lathrop

face picon face
> I am busy trying to program a 12f675 to flash an LED. When I compile my
> code in MPLab I get message [302]: 'Register in operand not in bank0'.

This gets asked repeatedly.  See archives.


*****************************************************************
Embed Inc, embedded system specialists in Littleton Massachusetts
(978) 742-9014, http://www.embedinc.com

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads

2003\04\22@104707 by Jason Dini

flavicon
face
Thanks for the feedback. After a look at the archives I found somebody with
a similar problem to mine that had forgotten to switch off the A/D
converter. Unfortunately I don't have my code in front of me to check
this(I'm almost sure I switched it off though)so I'll only be able to check
this later.

Regards
Jason


{Quote hidden}

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads

More... (looser matching)
- Last day of these posts
- In 2003 , 2004 only
- Today
- New search...